#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)dr(?:.(?!last|statement|available))*\.html"
Local $sString = "'/directory/index.html'," & @CRLF & _
" '/index.html'," & @CRLF & _
" '#'," & @CRLF & _
" '/index.html'," & @CRLF & _
" '/kss_how.html'," & @CRLF & _
" 'dr_info/swearingenlarry.html'," & @CRLF & _
" 'dr_info/swearingenlarrylast.html'," & @CRLF & _
" 'dr_info/kingjohn.html'," & @CRLF & _
" 'dr_info/kingjohnlast.html'," & @CRLF & _
" 'dr_info/_coble.jpg'," & @CRLF & _
" 'dr_info/coblebillielast.html'," & @CRLF & _
" 'dr_info/netherystephen.jpg'," & @CRLF & _
" 'dr_info/netherystephenlast.html'," & @CRLF & _
" 'dr_info/rougeaupaul.jpg'," & @CRLF & _
" 'dr_info/no_last_statement.html'," & @CRLF & _
" 'dr_info/no_info_available.html'," & @CRLF & _
" 'dr_info/no_last_statement.html'," & @CRLF & _
" 'dr_info/no_last_statement.html'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")