re = /dr(?:.(?!last|statement|available))*\.html/m
str = '\'/directory/index.html\',
\'/index.html\',
\'#\',
\'/index.html\',
\'/kss_how.html\',
\'dr_info/swearingenlarry.html\',
\'dr_info/swearingenlarrylast.html\',
\'dr_info/kingjohn.html\',
\'dr_info/kingjohnlast.html\',
\'dr_info/_coble.jpg\',
\'dr_info/coblebillielast.html\',
\'dr_info/netherystephen.jpg\',
\'dr_info/netherystephenlast.html\',
\'dr_info/rougeaupaul.jpg\',
\'dr_info/no_last_statement.html\',
\'dr_info/no_info_available.html\',
\'dr_info/no_last_statement.html\',
\'dr_info/no_last_statement.html\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end