import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dr(?:.(?!last|statement|available))*\\.html";
final String string = "'/directory/index.html',\n"
+ " '/index.html',\n"
+ " '#',\n"
+ " '/index.html',\n"
+ " '/kss_how.html',\n"
+ " 'dr_info/swearingenlarry.html',\n"
+ " 'dr_info/swearingenlarrylast.html',\n"
+ " 'dr_info/kingjohn.html',\n"
+ " 'dr_info/kingjohnlast.html',\n"
+ " 'dr_info/_coble.jpg',\n"
+ " 'dr_info/coblebillielast.html',\n"
+ " 'dr_info/netherystephen.jpg',\n"
+ " 'dr_info/netherystephenlast.html',\n"
+ " 'dr_info/rougeaupaul.jpg',\n"
+ " 'dr_info/no_last_statement.html',\n"
+ " 'dr_info/no_info_available.html',\n"
+ " 'dr_info/no_last_statement.html',\n"
+ " 'dr_info/no_last_statement.html'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}