using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^protocol://.+/folder/index\.html($|\?param=.+)";
string input = @"protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=test1234&a=1&b=234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890
protocol:// /folder/index.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}