package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^protocol://.+/folder/index\.html($|\?param=.+)`)
var str = `protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=test1234&a=1&b=234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890
protocol:// /folder/index.html
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}