$re = '`^protocol://.+/folder/index\.html($|\?param=.+)`m';
$str = 'protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=test1234&a=1&b=234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890
protocol:// /folder/index.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);