package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/(.*)?\/([a-z]{0,2})\/?(buy|kauf)\/([a-zA-Z0-9-+]+)$`)
var str = `https://www.example.com/buy/apartment
https://www.example.com/de/kauf/appartement
https://www.example.com/en/all-objects https://www.example.com/contact`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}