$re = '/https:\/\/(.*)?\/([a-z]{0,2})\/?(buy|kauf)\/([a-zA-Z0-9-+]+)$/m';
$str = 'https://www.example.com/buy/apartment
https://www.example.com/de/kauf/appartement
https://www.example.com/en/all-objects https://www.example.com/contact';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);