import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(.*)?\\/([a-z]{0,2})\\/?(buy|kauf)\\/([a-zA-Z0-9-+]+)$";
final String string = "https://www.example.com/buy/apartment\n"
+ "https://www.example.com/de/kauf/appartement\n"
+ "https://www.example.com/en/all-objects https://www.example.com/contact";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}