import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([?\\[\\]])";
final String string = "[Input]\n"
+ "NewAutoController = New Input:\n"
+ "ControllerDisconnect = The controller has disconnected. Please re-connect the controller to resume.\n\n"
+ "[levels]\n"
+ "Chapter = Chapter\n"
+ "Act = Act\n"
+ "MountainPeak = Mountain Peak\n"
+ "FreeRoamDesc = Do Whatever You'd Like\n\n"
+ "[coop]\n"
+ "SyncBusyWait0 = Waiting for player 1!\n"
+ "SyncBusyWait1 = Waiting for player 2!\n\n"
+ "[cheats]\n"
+ "disallowed_outside_editor = Not in Editor\n\n"
+ "[Console]\n"
+ "OfflineMode = Do you want to play offline? Xbox Live features won't be available and data will not save.\n"
+ "FailedLogin = Unable to log in at this time. Please wait and try again.\n"
+ "Yes = Yes\n"
+ "No = No";
final String subst = "\\\\$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}