# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([?\[\]])"
test_str = ("[Input]\n"
"NewAutoController = New Input:\n"
"ControllerDisconnect = The controller has disconnected. Please re-connect the controller to resume.\n\n"
"[levels]\n"
"Chapter = Chapter\n"
"Act = Act\n"
"MountainPeak = Mountain Peak\n"
"FreeRoamDesc = Do Whatever You'd Like\n\n"
"[coop]\n"
"SyncBusyWait0 = Waiting for player 1!\n"
"SyncBusyWait1 = Waiting for player 2!\n\n"
"[cheats]\n"
"disallowed_outside_editor = Not in Editor\n\n"
"[Console]\n"
"OfflineMode = Do you want to play offline? Xbox Live features won't be available and data will not save.\n"
"FailedLogin = Unable to log in at this time. Please wait and try again.\n"
"Yes = Yes\n"
"No = No")
subst = "\\\\$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.