package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{5,11}(?:,[0-9]{5,11})*$`)
var str = `0123456789,012345,012345678,01234567890
0123456789
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}