$re = '/^[0-9]{5,11}(?:,[0-9]{5,11})*$/m';
$str = '0123456789,012345,012345678,01234567890
0123456789
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);