re = /^[0-9]{5,11}(?:,[0-9]{5,11})*$/m
str = '0123456789,012345,012345678,01234567890
0123456789
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end