import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\.)(\\b[a-zA-Z_]+[a-zA-Z0-9_]+)\\.[a-zA-Z0-9_\\.]+";
final String string = "module.func()\n"
+ "module.class.func()\n"
+ "module.module.class . func()\n"
+ "__module__.module.class.func()\n\n"
+ "module.constant\n"
+ "module.class.constant\n"
+ "module.class.class.constant\n\n"
+ "module11.func()\n"
+ "modu123le.class.func()\n"
+ "modu123le.module.class.func()\n"
+ "modu123le.module123.class.func()\n\n"
+ "\"1 if module11.func(col) == 'A' else 3\"\n"
+ "\"1 if module11.func(col) == 'A' else ( _module.constant == 'B') else 34\"\n\n"
+ "\"module.func()\"\n\n\n"
+ "1.0 \n"
+ "1module.func() \n"
+ "2module.class.func()\n"
+ "col.upper() ##No way to know whether col is a module \n\n"
+ "module . func() ##Need to remove spaces before and after .\n"
+ "module . class . func() \n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}