use strict;
my $str = 'module.func()
module.class.func()
module.module.class . func()
__module__.module.class.func()
module.constant
module.class.constant
module.class.class.constant
module11.func()
modu123le.class.func()
modu123le.module.class.func()
modu123le.module123.class.func()
"1 if module11.func(col) == \'A\' else 3"
"1 if module11.func(col) == \'A\' else ( _module.constant == \'B\') else 34"
"module.func()"
1.0
1module.func()
2module.class.func()
col.upper() ##No way to know whether col is a module
module . func() ##Need to remove spaces before and after .
module . class . func()
';
my $regex = qr/(?<!\.)(\b[a-zA-Z_]+[a-zA-Z0-9_]+)\.[a-zA-Z0-9_\.]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}