#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "!\w+(?=[^`]*(?:`[^`]*`[^`]*)*$)"
Local $sString = "!yes" & @CRLF & _
"" & @CRLF & _
"This is inline code `foo !no bar`." & @CRLF & _
"" & @CRLF & _
"!yes" & @CRLF & _
"" & @CRLF & _
"Fenced code:" & @CRLF & _
"" & @CRLF & _
"```txt" & @CRLF & _
"Some code" & @CRLF & _
"blah (!no) blah" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"only !yes should be matched not `!no`"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")