$re = '/!\w+(?=[^`]*(?:`[^`]*`[^`]*)*$)/';
$str = '!yes
This is inline code `foo !no bar`.
!yes
Fenced code:
```txt
Some code
blah (!no) blah
```
only !yes should be matched not `!no`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);