using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!\w+(?=[^`]*(?:`[^`]*`[^`]*)*$)";
string input = @"!yes
This is inline code `foo !no bar`.
!yes
Fenced code:
```txt
Some code
blah (!no) blah
```
only !yes should be matched not `!no`";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}