#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a href="([^"]*?\/n\/\?confirm\.php)">.*?<\/a>"
Local $sString = "<a href="https://www.website.com/n/?noconfirm.php">SSD</a>" & @CRLF & _
"<div>How are you</div>" & @CRLF & _
"<a href="https://www.website.com/n/?confirm.php">HDD</a>" & @CRLF & _
"<h2>Being Sunny</h2>" & @CRLF & _
"<a href="https://www.website.com/n/?noconfirm.php">MSD</a>" & @CRLF & _
"<div>How are you</div>" & @CRLF & _
"<a href="https://www.website.com/n/?confirm.php"></a>" & @CRLF & _
"<h2>Being Sunny</h2>" & @CRLF & _
"<a href="https://www.website.com/n/?noconfirm.php">GSD</a>" & @CRLF & _
"<div>How are you</div>" & @CRLF & _
"<a href="https://www.website.com/n/?confirm.php">LSD</a>" & @CRLF & _
"<h2>Being Sunny</h2>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")