import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\"([^\"]*?\\/n\\/\\?confirm\\.php)\">.*?<\\/a>";
final String string = "<a href=\"https://www.website.com/n/?noconfirm.php\">SSD</a>\n"
+ "<div>How are you</div>\n"
+ "<a href=\"https://www.website.com/n/?confirm.php\">HDD</a>\n"
+ "<h2>Being Sunny</h2>\n"
+ "<a href=\"https://www.website.com/n/?noconfirm.php\">MSD</a>\n"
+ "<div>How are you</div>\n"
+ "<a href=\"https://www.website.com/n/?confirm.php\"></a>\n"
+ "<h2>Being Sunny</h2>\n"
+ "<a href=\"https://www.website.com/n/?noconfirm.php\">GSD</a>\n"
+ "<div>How are you</div>\n"
+ "<a href=\"https://www.website.com/n/?confirm.php\">LSD</a>\n"
+ "<h2>Being Sunny</h2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}