// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a href="([^"]*?\/n\/\?confirm\.php)">.*?<\/a>"#).unwrap();
let string = "<a href=\"https://www.website.com/n/?noconfirm.php\">SSD</a>
<div>How are you</div>
<a href=\"https://www.website.com/n/?confirm.php\">HDD</a>
<h2>Being Sunny</h2>
<a href=\"https://www.website.com/n/?noconfirm.php\">MSD</a>
<div>How are you</div>
<a href=\"https://www.website.com/n/?confirm.php\"></a>
<h2>Being Sunny</h2>
<a href=\"https://www.website.com/n/?noconfirm.php\">GSD</a>
<div>How are you</div>
<a href=\"https://www.website.com/n/?confirm.php\">LSD</a>
<h2>Being Sunny</h2>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}