using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?1.{0,5}2.*|^.*?2(*COMMIT)3.*";
string input = @"1.....23
1.....21
23......
12.....1
1...2...
....23..
213....2
1......2
213....3
2.....21";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}