use strict;
my $str = '1.....23
1.....21
23......
12.....1
1...2...
....23..
213....2
1......2
213....3
2.....21';
my $regex = qr/^.*?1.{0,5}2.*|^.*?2(*COMMIT)3.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}