re = /^.*?1.{0,5}2.*|^.*?2(*COMMIT)3.*/m
str = '1.....23
1.....21
23......
12.....1
1...2...
....23..
213....2
1......2
213....3
2.....21'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end