using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]+([0-9]+)?)|([_$][a-zA-Z]+([0-9]+)?)";
string input = @"as2
var15
_num1
$num1
$i
_i";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}