// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z]+([0-9]+)?)|([_$][a-zA-Z]+([0-9]+)?)").unwrap();
let string = "as2
var15
_num1
$num1
$i
_i";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}