re = /([a-zA-Z]+([0-9]+)?)|([_$][a-zA-Z]+([0-9]+)?)/
str = 'as2
var15
_num1
$num1
$i
_i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end