$re = '/^[^-\n]+-([^-\n]+)/m';
$str = '1234-ABC
1234-abc
1234-ABC-1a
1234
1234-abc-test-this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);