re = /^[^-\n]+-([^-\n]+)/m
str = '1234-ABC
1234-abc
1234-ABC-1a
1234
1234-abc-test-this'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end