#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:^(?!.*\bways\b)|\G(?!\A)).*?)\b(apple|banana|work)\b"
Local $sString = "I have not failed. I've just found 10,000 ways that won't work. A banana and an apple" & @CRLF & _
"I have not failed. I've just found 10,000 way that won't work. A banana and an apple"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")