using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:^(?!.*\bways\b)|\G(?!\A)).*?)\b(apple|banana|work)\b";
string input = @"I have not failed. I've just found 10,000 ways that won't work. A banana and an apple
I have not failed. I've just found 10,000 way that won't work. A banana and an apple";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}