$re = '/(?:(?:^(?!.*\bways\b)|\G(?!\A)).*?)\b(apple|banana|work)\b/m';
$str = 'I have not failed. I\'ve just found 10,000 ways that won\'t work. A banana and an apple
I have not failed. I\'ve just found 10,000 way that won\'t work. A banana and an apple';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);