const regex = new RegExp('(([\\(\\[])?([(?:IWantOut|WeWantOut)\\w\\.])+?([\\)\\]])?(\\W*\\s*-*—*(>)+)\\s*([\\(\\[])?[\\w\\/\\\\,\\s]+([\\)\\]])?)', 'gsm')
const str = `us----> canada
[IWantOut] 25F Japan-> USA/UK
[EU] -> [AUS] Question about document translation
(22F) -> Germany;
Looking for someone with experience moving out of USA to --->(Japan, Korea, Western Europe, or Australia)? AKA, a mentor?
We want out U.S.->France;
USA -> South America`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}