use strict;
my $str = 'us----> canada
[IWantOut] 25F Japan-> USA/UK
[EU] -> [AUS] Question about document translation
(22F) -> Germany;
Looking for someone with experience moving out of USA to --->(Japan, Korea, Western Europe, or Australia)? AKA, a mentor?
We want out U.S.->France;
USA -> South America';
my $regex = qr/(([\(\[])?([(?:IWantOut|WeWantOut)\w\.])+?([\)\]])?(\W*\s*-*—*(>)+)\s*([\(\[])?[\w\/\\,\s]+([\)\]])?)/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}