re = /(([\(\[])?([(?:IWantOut|WeWantOut)\w\.])+?([\)\]])?(\W*\s*-*—*(>)+)\s*([\(\[])?[\w\/\\,\s]+([\)\]])?)/m
str = 'us----> canada
[IWantOut] 25F Japan-> USA/UK
[EU] -> [AUS] Question about document translation
(22F) -> Germany;
Looking for someone with experience moving out of USA to --->(Japan, Korea, Western Europe, or Australia)? AKA, a mentor?
We want out U.S.->France;
USA -> South America'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end