package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z][A-Z][A-Z][A-Z][[0-9][[0-9][[0-9][[0-9][[0-9][[0-9][H|M][A-Z][A-Z][A-Z][A-Z][A-Z][0-9][0-9]`)
var str = `GAPF771001HNELLB16
abc
Abc
ABc
AbC
aBC
AbC
AbC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}