re = /[A-Z][A-Z][A-Z][A-Z][[0-9][[0-9][[0-9][[0-9][[0-9][[0-9][H|M][A-Z][A-Z][A-Z][A-Z][A-Z][0-9][0-9]/m
str = 'GAPF771001HNELLB16
abc
Abc
ABc
AbC
aBC
AbC
AbC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end