const regex = new RegExp('[A-Z][A-Z][A-Z][A-Z][[0-9][[0-9][[0-9][[0-9][[0-9][[0-9][H|M][A-Z][A-Z][A-Z][A-Z][A-Z][0-9][0-9]', 'gm')
const str = `GAPF771001HNELLB16
abc
Abc
ABc
AbC
aBC
AbC
AbC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}