using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*#(\d++)(?:[^.\r\n].*)?$";
string input = @"earth is #8746253.Kms away, which is very far
my car number is #8746253 which is actually cool
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}