package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*#(\d++)(?:[^.\r\n].*)?$`)
var str = `earth is #8746253.Kms away, which is very far
my car number is #8746253 which is actually cool
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}