// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*#(\d++)(?:[^.\r\n].*)?$").unwrap();
let string = "earth is #8746253.Kms away, which is very far
my car number is #8746253 which is actually cool
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}