#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"responseJson",({".+)\)"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html lang="en-us">" & @CRLF & _
"<head>" & @CRLF & _
" <title>Text</title>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
" <div class="pane" role="main" onclick="void(0)">" & @CRLF & _
" <div id="text" class="container tooltip-hide"></div>" & @CRLF & _
" </div>" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
" Classify("cs.services/GlobalObject").set({" & @CRLF & _
" pageContext: ""," & @CRLF & _
" countryCode: "us"," & @CRLF & _
" langCode: "en"," & @CRLF & _
" errorMsg: """ & @CRLF & _
" });" & @CRLF & _
" Classify("cs.services/GlobalObject").set("userObj", 'null');" & @CRLF & _
" Classify("cs.services/GlobalObject").set("countryLangLinks", '{"code":"us","languages":[{"code":"en","label":"English","selected":true},{"code":"es","label":"Español","selected":false}],"action":"/us/en/country","label":"United States"}');" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
" <script>" & @CRLF & _
" Classify("cs.services/GlobalObject").set("responseJson",{"DISPUTE_MESSAGE":"Test","results":[{"resultText":"LALALA."},{"resultText":"TEXT HERE"},{"resultText":"123"}],"STATUS":"OK","REG":"Y", "Info":{"text":"123","text2":"3","image":"url","id":"12345"}});" & @CRLF & _
" Classify("cs.services/GlobalObject").set("responseJson.LINK_URL","/us/en/");" & @CRLF & _
" Classify("cs.services/GlobalObject").set("callerId","ccweb");" & @CRLF & _
" </script>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")