using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""responseJson"",({"".+)\)";
string input = @"<!DOCTYPE html>
<html lang=""en-us"">
<head>
<title>Text</title>
</head>
<body>
<div class=""pane"" role=""main"" onclick=""void(0)"">
<div id=""text"" class=""container tooltip-hide""></div>
</div>
<script type=""text/javascript"">
Classify(""cs.services/GlobalObject"").set({
pageContext: "",
countryCode: ""us"",
langCode: ""en"",
errorMsg: ""
});
Classify(""cs.services/GlobalObject"").set(""userObj"", 'null');
Classify(""cs.services/GlobalObject"").set(""countryLangLinks"", '{""code"":""us"",""languages"":[{""code"":""en"",""label"":""English"",""selected"":true},{""code"":""es"",""label"":""Español"",""selected"":false}],""action"":""/us/en/country"",""label"":""United States""}');
</script>
<script>
Classify(""cs.services/GlobalObject"").set(""responseJson"",{""DISPUTE_MESSAGE"":""Test"",""results"":[{""resultText"":""LALALA.""},{""resultText"":""TEXT HERE""},{""resultText"":""123""}],""STATUS"":""OK"",""REG"":""Y"", ""Info"":{""text"":""123"",""text2"":""3"",""image"":""url"",""id"":""12345""}});
Classify(""cs.services/GlobalObject"").set(""responseJson.LINK_URL"",""/us/en/"");
Classify(""cs.services/GlobalObject"").set(""callerId"",""ccweb"");
</script>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}