use strict;
my $str = '<!DOCTYPE html>
<html lang="en-us">
<head>
<title>Text</title>
</head>
<body>
<div class="pane" role="main" onclick="void(0)">
<div id="text" class="container tooltip-hide"></div>
</div>
<script type="text/javascript">
Classify("cs.services/GlobalObject").set({
pageContext: "",
countryCode: "us",
langCode: "en",
errorMsg: ""
});
Classify("cs.services/GlobalObject").set("userObj", \'null\');
Classify("cs.services/GlobalObject").set("countryLangLinks", \'{"code":"us","languages":[{"code":"en","label":"English","selected":true},{"code":"es","label":"Español","selected":false}],"action":"/us/en/country","label":"United States"}\');
</script>
<script>
Classify("cs.services/GlobalObject").set("responseJson",{"DISPUTE_MESSAGE":"Test","results":[{"resultText":"LALALA."},{"resultText":"TEXT HERE"},{"resultText":"123"}],"STATUS":"OK","REG":"Y", "Info":{"text":"123","text2":"3","image":"url","id":"12345"}});
Classify("cs.services/GlobalObject").set("responseJson.LINK_URL","/us/en/");
Classify("cs.services/GlobalObject").set("callerId","ccweb");
</script>
</body>
</html>';
my $regex = qr/"responseJson",({".+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}