#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).+sites\/.+\/archive\/folder.+"
Local $sString = "/sites/site1/archive/folder/" & @CRLF & _
"/sites/site1/archive/other/" & @CRLF & _
"/sites/site2/archive/folder/" & @CRLF & _
"/sites/site2/archive/other/" & @CRLF & _
"/sites/site3/other/folder/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")