package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).+sites\/.+\/archive\/folder.+`)
var str = `/sites/site1/archive/folder/
/sites/site1/archive/other/
/sites/site2/archive/folder/
/sites/site2/archive/other/
/sites/site3/other/folder/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}