// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i).+sites\/.+\/archive\/folder.+").unwrap();
let string = "/sites/site1/archive/folder/
/sites/site1/archive/other/
/sites/site2/archive/folder/
/sites/site2/archive/other/
/sites/site3/other/folder/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}