using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+sites\/.+\/archive\/(?!folder).+";
string input = @"/sites/site1/archive/folder/
/sites/site1/archive/other/
/sites/site2/archive/folder/
/sites/site2/archive/other/
/sites/site3/other/folder/";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}