re = /.+sites\/.+\/archive\/(?!folder).+/i
str = '/sites/site1/archive/folder/
/sites/site1/archive/other/
/sites/site2/archive/folder/
/sites/site2/archive/other/
/sites/site3/other/folder/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end